<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://thebalochistanpoint.com/xmlrpc.php" />
<title>We struggle for Baloch rights more than Baloch nationalist: Abdul Ghafoor Haideri &#8211; Balochistan Point</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Balochistan Point &raquo; Feed" href="http://thebalochistanpoint.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Balochistan Point &raquo; Comments Feed" href="http://thebalochistanpoint.com/comments/feed/" />
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/thebalochistanpoint.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","share_counts_url":"http:\/\/thebalochistanpoint.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"},"url_components":{"year":"2020","monthnum":"04","day":"30","post_id":"17106","postname":"we-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri","author":"admin"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false'
        src='//apps.shareaholic.com/assets/pub/shareaholic.js'
        data-shr-siteid='de1be215d5406b05a76a814548536503' async='async' >
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Balochistan Point' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://thebalochistanpoint.com/we-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri/' />
<meta name='shareaholic:keywords' content='interviews, multi media, national, videos, post' />
<meta name='shareaholic:article_published_time' content='2020-04-30T00:46:19+00:00' />
<meta name='shareaholic:article_modified_time' content='2020-04-30T01:11:40+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='admin' />
<meta name='shareaholic:site_id' content='de1be215d5406b05a76a814548536503' />
<meta name='shareaholic:wp_version' content='8.5.3' />
<meta name='shareaholic:image' content='http://thebalochistanpoint.com/wp-content/uploads/2020/04/l_221756_043307_print.jpg' />
<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thebalochistanpoint.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tie-style-css'  href='http://thebalochistanpoint.com/wp-content/themes/jarida/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css'  href='http://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-channel-gallery-css'  href='http://thebalochistanpoint.com/wp-content/plugins/youtube-channel-gallery/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery.magnific-popup-css'  href='http://thebalochistanpoint.com/wp-content/plugins/youtube-channel-gallery/magnific-popup.css' type='text/css' media='all' />
<script type='text/javascript' src='http://thebalochistanpoint.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://thebalochistanpoint.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='http://thebalochistanpoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thebalochistanpoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://thebalochistanpoint.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Sindh governor tests positive' href='http://thebalochistanpoint.com/sindh-governor-tests-positive-as-coronavirus/' />
<meta name="generator" content="WordPress 4.8.12" />
<link rel="canonical" href="http://thebalochistanpoint.com/we-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri/" />
<link rel='shortlink' href='http://thebalochistanpoint.com/?p=17106' />
<link rel="alternate" type="application/json+oembed" href="http://thebalochistanpoint.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthebalochistanpoint.com%2Fwe-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thebalochistanpoint.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthebalochistanpoint.com%2Fwe-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri%2F&#038;format=xml" />

<!-- BlogPress - A Native WordPress Android App version 2.6 - Developed by WDDPortfolio.com -->
<meta property="fb:app_id" content="1727391854220459"/>
<!-- Contact Us Form -->
<style type="text/css">
.cuf_input {display:none !important; visibility:hidden !important;}
#contactsubmit:hover, #contactsubmit:focus {
	background: #849F00 repeat-x;
	color: #FFF;
	text-decoration: none;
}
#contactsubmit:active {background: #849F00}
#contactsubmit {
	color: #FFF;
	margin-top:5px;
	margin-bottom:5px;
	background: #738c00 repeat-x;
	display: block;
	float: left;
	/*height: 28px;*/
	padding-right: 23px;
	padding-left: 23px;
	font-size: 12px;
	text-transform: uppercase;
	text-decoration: none;
	font-weight: bold;
	text-shadow: 0px 1px 0px rgba(0, 0, 0, 0.2);
	filter: dropshadow(color=rgba(0, 0, 0, 0.2), offx=0, offy=1);
	-webkit-border-radius: 5px;
	-moz-border-radius: 5px;
	border-radius: 5px;
	-webkit-transition: background 300ms linear;
-moz-transition: background 300ms linear;
-o-transition: background 300ms linear;
transition: background 300ms linear;
-webkit-box-shadow: 0px 2px 2px 0px rgba(0, 0, 0, 0.2);
-moz-box-shadow: 0px 2px 2px 0px rgba(0, 0, 0, 0.2);
box-shadow: 0px 2px 2px 0px rgba(0, 0, 0, 0.2);
text-align:center
}
#tinyform {
clear: both;
width:500px;
	margin-left:auto;
	margin-right:auto;
	/*margin-top:30px;*/
	padding:20px;
	padding-bottom:0px;
	-webkit-border-radius:5px;
	-moz-border-radius:5px;
	border-radius:5px;
	-webkit-box-shadow:0px 0px 10px 0px rgba(0,0,0,0.2);
	-moz-box-shadow:0px 0px 10px 0px rgba(0,0,0,0.2);
	box-shadow:0px 0px 10px 0px rgba(0,0,0,0.2);
	border:4px solid #FFF;
	-webkit-transition:all 200ms linear;
	-moz-transition:all 200ms linear;
	-o-transition:all 200ms linear;
	transition:all 200ms linear;
}
.cuf_field_1 {
	margin-bottom:10px;
}
.cuf_field {
	-moz-box-sizing:border-box;
	-webkit-box-sizing:border-box;
	box-sizing:border-box;
	background:#fff;
	border:1px solid #A9B3BC;
	padding:8px;
	width:100%;
	margin-top:5px;
margin-bottom:15px;
	outline:none
}
.cuf_textarea {
	-moz-box-sizing:border-box;
	-webkit-box-sizing:border-box;
	box-sizing:border-box;
	background:#fff;
	border:1px solid #A9B3BC;
	padding:8px;
	width:100%;
	margin-top:5px;
	outline:none;
margin-bottom:15px;
}


</style>

	<!-- begin gallery scripts -->
    <link rel="stylesheet" href="http://thebalochistanpoint.com/wp-content/plugins/featured-content-gallery/css/jd.gallery.css.php" type="text/css" media="screen" charset="utf-8"/>
	<link rel="stylesheet" href="http://thebalochistanpoint.com/wp-content/plugins/featured-content-gallery/css/jd.gallery.css" type="text/css" media="screen" charset="utf-8"/>
	<script type="text/javascript" src="http://thebalochistanpoint.com/wp-content/plugins/featured-content-gallery/scripts/mootools.v1.11.js"></script>
	<script type="text/javascript" src="http://thebalochistanpoint.com/wp-content/plugins/featured-content-gallery/scripts/jd.gallery.js.php"></script>
	<script type="text/javascript" src="http://thebalochistanpoint.com/wp-content/plugins/featured-content-gallery/scripts/jd.gallery.transitions.js"></script>
	<!-- end gallery scripts -->
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 12px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>
<link rel="shortcut icon" href="http://thebalochistanpoint.com/wp-content/uploads/2013/06/fav1.png" title="Favicon" /><!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="http://thebalochistanpoint.com/wp-content/themes/jarida/js/html5.js"></script>
<script src="http://thebalochistanpoint.com/wp-content/themes/jarida/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://thebalochistanpoint.com/wp-content/themes/jarida/css/ie8.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" />
<style type="text/css" media="screen">

body {
 background-image : url(http://thebalochistanpoint.com/wp-content/themes/jarida/images/patterns/body-bg10.png);background-position: top center;
}
	
body.single .entry, body.page .entry{
	font-family: Georgia, serif;
	font-size : 16px !important;
}



</style>
<style>
.single-post-thumb {
 background: #2c2c2c;
text-align: center;
}

.single-post-thumb  img{
width: 400px;
margin-top:3px;
}
</style>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-53177736-2', 'auto');
  ga('send', 'pageview');

</script>
</head>
<body id="top" class="post-template-default single single-post postid-17106 single-format-standard">
	<div class="background-cover"></div>
	<div class="wrapper">
				<div class="top-nav fade-in animated1 head_brnews">
			<div class="container">
				<div class="search-block">
					<form method="get" id="searchform" action="http://thebalochistanpoint.com/">
						<button class="search-button" type="submit" value="Search"></button>
						<input type="text" id="s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}"  />
					</form>
				</div><!-- .search-block /-->
						<div class="social-icons icon_flat">
		<a class="tooldown" title="Rss" href="http://thebalochistanpoint.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="tooldown" title="Facebook" href="http://www.facebook.com/Balochistan.Point" target="_blank"><i class="tieicon-facebook"></i></a><a class="tooldown" title="Twitter" href="http://twitter.com/TheB_Point" target="_blank"><i class="tieicon-twitter"></i></a>	</div>


					
	<div class="breaking-news">
		<span>Latest News</span>
				
					<ul>
							<li><a href="http://thebalochistanpoint.com/sindh-governor-tests-positive-as-coronavirus/" title="Sindh governor tests positive">Sindh governor tests positive</a></li>
							<li><a href="http://thebalochistanpoint.com/17078-2/" title="Exclusive Interview of Educationist Zahir Hussain Baloch">Exclusive Interview of Educationist Zahir Hussain Baloch</a></li>
							<li><a href="http://thebalochistanpoint.com/covid-19-political-economic-and-social-impact-debated/" title="COVID-19: Political, Economic and Social Impact Debated">COVID-19: Political, Economic and Social Impact Debated</a></li>
							<li><a href="http://thebalochistanpoint.com/balochistan-is-deprived-of-its-natural-gas-syed-mehmood-shah/" title="Balochistan is deprived of its natural Gas: Syed Mehmood Shah">Balochistan is deprived of its natural Gas: Syed Mehmood Shah</a></li>
							<li><a href="http://thebalochistanpoint.com/unhcrs-skills-project-empowered-refugee-woman-to-earn-at-home-amid-coronavirus-outbreak/" title="UNHCR’s skills project empowered refugee woman to earn at home amid coronavirus outbreak">UNHCR’s skills project empowered refugee woman to earn at home amid coronavirus outbreak</a></li>
							<li><a href="http://thebalochistanpoint.com/coronavirus-people-want-restoration-of-mobile-internet-in-balochistan/" title="Coronavirus: People Want Restoration of Mobile Internet in Balochistan">Coronavirus: People Want Restoration of Mobile Internet in Balochistan</a></li>
							<li><a href="http://thebalochistanpoint.com/awareness-session-conducted-in-zhob-to-educate-the-masses-about-coronavirus-pandemic/" title="Awareness session conducted in Zhob to educate the masses about Coronavirus pandemic">Awareness session conducted in Zhob to educate the masses about Coronavirus pandemic</a></li>
							<li><a href="http://thebalochistanpoint.com/bwf-announces-its-organizing-body-to-work-for-women-empowerment/" title="BWF announces its organizing body to work for women empowerment ">BWF announces its organizing body to work for women empowerment </a></li>
							<li><a href="http://thebalochistanpoint.com/anti-harassment-committees-havent-been-established-yet-in-all-govt-and-non-governmental-organizations-of-balochistan/" title="Anti-harassment committees haven’t been established yet in all govt and non-governmental organizations of Balochistan">Anti-harassment committees haven’t been established yet in all govt and non-governmental organizations of Balochistan</a></li>
							<li><a href="http://thebalochistanpoint.com/the-united-states-educational-foundation-in-pakistan-announces-2021-fulbright-student-masters-and-phd-program/" title="The United States Educational Foundation in Pakistan Announces 2021 Fulbright Student (Master’s and PhD) Program">The United States Educational Foundation in Pakistan Announces 2021 Fulbright Student (Master’s and PhD) Program</a></li>
							<li><a href="http://thebalochistanpoint.com/balochabad-and-female-education/" title="Balochabad and Female Education">Balochabad and Female Education</a></li>
							<li><a href="http://thebalochistanpoint.com/mercs-balochistan-project-director-visits-rescue-headquarters/" title="MERCs Balochistan Project Director Visits Rescue Headquarters">MERCs Balochistan Project Director Visits Rescue Headquarters</a></li>
							<li><a href="http://thebalochistanpoint.com/agahi-announces-pakistan-2029-state-of-future-index-report/" title="AGAHI announces Pakistan 2029, State of Future Index Report">AGAHI announces Pakistan 2029, State of Future Index Report</a></li>
							<li><a href="http://thebalochistanpoint.com/golden-jubilee-of-government-atta-shad-degree-college-turbat/" title="Golden Jubilee of Government Atta Shad Degree College Turbat">Golden Jubilee of Government Atta Shad Degree College Turbat</a></li>
							<li><a href="http://thebalochistanpoint.com/internet-access-the-need-of-the-hour-in-makran/" title="Internet access: The need of the hour in Makran">Internet access: The need of the hour in Makran</a></li>
							<li><a href="http://thebalochistanpoint.com/khuzdar-transparency-and-citizens-participation-in-budget-making-process-found-lacking-at-district-level-in-baluchistan-2/" title="KHUZDAR: Transparency and citizens’ participation in budget making process found lacking at district level in Baluchistan">KHUZDAR: Transparency and citizens’ participation in budget making process found lacking at district level in Baluchistan</a></li>
							<li><a href="http://thebalochistanpoint.com/medical-emergency-response-centers-commence-operations-at-kalat-and-khuzdar/" title="Medical Emergency Response Centers commence operations at Kalat and Khuzdar">Medical Emergency Response Centers commence operations at Kalat and Khuzdar</a></li>
							<li><a href="http://thebalochistanpoint.com/shirkat-gah-quetta-conducts-workshop-on-the-production-of-meaning-politics-of-representation/" title="Shirkat Gah-Quetta conducts workshop on  “The Production of Meaning &#038; Politics of Representation”">Shirkat Gah-Quetta conducts workshop on  “The Production of Meaning &#038; Politics of Representation”</a></li>
							<li><a href="http://thebalochistanpoint.com/balochistan-takes-the-lead-in-rule-of-law-reforms/" title="Balochistan Takes the Lead in Rule of Law Reforms">Balochistan Takes the Lead in Rule of Law Reforms</a></li>
							<li><a href="http://thebalochistanpoint.com/pakistan-has-the-second-highest-number-of-out-of-school-children-in-the-world/" title="Pakistan has the second-highest number of out-of-school children in the world.">Pakistan has the second-highest number of out-of-school children in the world.</a></li>
						</ul>
					
						<script type="text/javascript">
			jQuery(document).ready(function(){
								createTicker(); 
							});
		</script>
	</div> <!-- .breaking-news -->				
			</div>
		</div><!-- .top-menu /-->
		
		<div class="container">
		<header id="theme-header">
		<div class="header-content fade-in animated1">
			<div class="logo">
			<h2>								<a title="Balochistan Point" href="http://thebalochistanpoint.com/">
					<img src="http://thebalochistanpoint.com/wp-content/uploads/2013/06/test-2.png" alt="Balochistan Point" /><strong>Balochistan Point Voice of Nation</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>
		</div>
									<nav id="main-nav" class="fade-in animated2 fixed-enabled">
				<div class="container">
				<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-6" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-home"><a href="http://thebalochistanpoint.com">Home</a></li>
<li id="menu-item-706" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  menu-item-has-children"><a href="http://thebalochistanpoint.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-747" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/news/news-balochistan/">Balochistan</a></li>
	<li id="menu-item-6497" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="http://thebalochistanpoint.com/category/news/national/">National</a></li>
	<li id="menu-item-746" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="http://thebalochistanpoint.com/category/news/news-international/">Multi Media</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-704" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://thebalochistanpoint.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li id="menu-item-1014" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/editors-picks/">Editors&#8217; Picks</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-879" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://thebalochistanpoint.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-12359" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/blogs/">Blogs</a></li>
	<li id="menu-item-6498" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/letters/">Letters</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-872" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="http://thebalochistanpoint.com/category/interviews/">Interviews</a></li>
<li id="menu-item-12358" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://thebalochistanpoint.com/category/feature/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-12466" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/human-rights/">Human Rights</a></li>
	<li id="menu-item-12464" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/democratic-process/">Democratic Process</a></li>
	<li id="menu-item-12465" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/govt-accountability/">Govt Accountability</a></li>
	<li id="menu-item-12467" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/rule-of-law/">Rule of Law</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-12455" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://thebalochistanpoint.com/category/more/">More</a>
<ul class="sub-menu">
	<li id="menu-item-12458" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/education/">Education</a></li>
	<li id="menu-item-12459" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/health/">Health</a></li>
	<li id="menu-item-12457" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/culture/">Culture</a></li>
	<li id="menu-item-12456" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/agriculture/">Agriculture</a></li>
	<li id="menu-item-12460" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/literature/">Literature</a></li>
	<li id="menu-item-12461" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/livestock/">Livestock</a></li>
	<li id="menu-item-12462" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/science/">Science</a></li>
	<li id="menu-item-12463" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://thebalochistanpoint.com/category/sports/">Sports</a></li>
</ul> <!--End Sub Menu -->
</li>
<li id="menu-item-5219" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://thebalochistanpoint.com/contribute/">Contribute</a></li>
<li id="menu-item-875" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://thebalochistanpoint.com/contact-us/">Contact Us</a></li>
<li id="menu-item-738" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://thebalochistanpoint.com/about-us/">About Us</a></li>
<li id="menu-item-7586" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="http://thebalochistanpoint.com/team/">Team</a></li>
</ul></div>				</div>
			</nav><!-- .main-nav /-->
		</header><!-- #header /-->

	<div id="main-content" class="container fade-in animated3">
<div class="content-wrap">
	<div class="content">
		
		
		
		
		<article id="the-post" class="post-listing post-17106 post type-post status-publish format-standard has-post-thumbnail hentry category-interviews category-news-international category-national category-videos">
					<div class="single-post-thumb">
			 <img width="620" height="330" src="http://thebalochistanpoint.com/wp-content/uploads/2020/04/l_221756_043307_print-620x330.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="http://thebalochistanpoint.com/wp-content/uploads/2020/04/l_221756_043307_print-620x330.jpg 620w, http://thebalochistanpoint.com/wp-content/uploads/2020/04/l_221756_043307_print-300x160.jpg 300w" sizes="(max-width: 620px) 100vw, 620px" />		</div>
		

			<div class="post-inner">
				<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">We struggle for Baloch rights more than Baloch nationalist: Abdul Ghafoor Haideri</span></h1>

								<div class="entry">
					
					<div class="pf-content"><p style="text-align: center;"><iframe src="https://www.youtube.com/embed/3VOGc5PSSww" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div id="wpdevar_comment_1" style="width:100%;text-align:left;">
		<span style="padding: 10px;font-size:15px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;color:#000000;">Comments</span>
		<div class="fb-comments" data-href="http://thebalochistanpoint.com/we-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri/" data-order-by="reverse_time" data-numposts="7" data-width="100%" style="display:block;"></div></div><div class="printfriendly pf-alignright"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/print-button.png" alt="Print Friendly, PDF & Email" /></a></div></div><div class='shareaholic-canvas' data-app-id='15200113' data-app-id-name='post_below_content' data-app='share_buttons' data-title='We struggle for Baloch rights more than Baloch nationalist: Abdul Ghafoor Haideri' data-link='http://thebalochistanpoint.com/we-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri/' data-summary=''></div>					
					
									</div><!-- .entry /-->
								<span style="display:none" class="updated">2020-04-30</span>
								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="http://thebalochistanpoint.com/author/admin/" title="Posts by admin" rel="author">admin</a></strong></div>
				
				
			</div><!-- .post-inner -->
		</article><!-- .post-listing -->
		

		
				<div class="post-navigation">
			<div class="post-previous"><a href="http://thebalochistanpoint.com/sindh-governor-tests-positive-as-coronavirus/" rel="prev"><span>Previous:</span> Sindh governor tests positive</a></div>
			<div class="post-next"></div>
		</div><!-- .post-navigation -->
		
		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://thebalochistanpoint.com/sindh-governor-tests-positive-as-coronavirus/" title="Permalink to Sindh governor tests positive" rel="bookmark">
						<img width="300" height="160" src="http://thebalochistanpoint.com/wp-content/uploads/2020/04/sindh-governor-imran-ismail-tests-positive-for-coronavirus-1588012497-7500-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" srcset="http://thebalochistanpoint.com/wp-content/uploads/2020/04/sindh-governor-imran-ismail-tests-positive-for-coronavirus-1588012497-7500-300x160.jpg 300w, http://thebalochistanpoint.com/wp-content/uploads/2020/04/sindh-governor-imran-ismail-tests-positive-for-coronavirus-1588012497-7500-620x330.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" />											</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://thebalochistanpoint.com/sindh-governor-tests-positive-as-coronavirus/" title="Permalink to Sindh governor tests positive" rel="bookmark">Sindh governor tests positive</a></h3>
				<p class="post-meta"><span class="tie-date">2 hours ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://thebalochistanpoint.com/poor-performance-of-agriculture-department-causes-low-production-in-balochistan/" title="Permalink to Poor performance of agriculture department causes low production in Balochistan" rel="bookmark">
						<img width="300" height="160" src="http://thebalochistanpoint.com/wp-content/uploads/2020/04/pic_1584814514-3-620x330-1-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" />											</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://thebalochistanpoint.com/poor-performance-of-agriculture-department-causes-low-production-in-balochistan/" title="Permalink to Poor performance of agriculture department causes low production in Balochistan" rel="bookmark">Poor performance of agriculture department causes low production in Balochistan</a></h3>
				<p class="post-meta"><span class="tie-date">9 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://thebalochistanpoint.com/17078-2/" title="Permalink to Exclusive Interview of Educationist Zahir Hussain Baloch" rel="bookmark">
						<img width="300" height="160" src="http://thebalochistanpoint.com/wp-content/uploads/2020/04/pic_1584814514-2-597x330-1-300x160.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" />											</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://thebalochistanpoint.com/17078-2/" title="Permalink to Exclusive Interview of Educationist Zahir Hussain Baloch" rel="bookmark">Exclusive Interview of Educationist Zahir Hussain Baloch</a></h3>
				<p class="post-meta"><span class="tie-date">9 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
		
		
	</div><!-- .content -->
<aside class="sidebar-narrow">
<div id="ads160_600-widget-2" class="widget ads160_600-widget"><div class="widget-top"><h4> Sponsor</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div  class="ads160-600">
							</div>
	</div></div><!-- .widget /--></aside>
</div> <!-- .content-wrap -->
<aside class="sidebar">
		<div id="recent-posts-2" class="widget widget_recent_entries">		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<ul>
					<li>
				<a href="http://thebalochistanpoint.com/we-struggle-for-baloch-rights-more-than-baloch-nationalist-abdul-ghafoor-haideri/">We struggle for Baloch rights more than Baloch nationalist: Abdul Ghafoor Haideri</a>
						</li>
					<li>
				<a href="http://thebalochistanpoint.com/sindh-governor-tests-positive-as-coronavirus/">Sindh governor tests positive</a>
						</li>
					<li>
				<a href="http://thebalochistanpoint.com/the-window-was-open/">The window was open</a>
						</li>
					<li>
				<a href="http://thebalochistanpoint.com/book-review-the-secret-garden/">Book Review: The Secret Garden</a>
						</li>
					<li>
				<a href="http://thebalochistanpoint.com/poor-performance-of-agriculture-department-causes-low-production-in-balochistan/">Poor performance of agriculture department causes low production in Balochistan</a>
						</li>
				</ul>
		</div></div><!-- .widget /-->		<div id="text-3" class="widget widget_text"><div class="widget-top"><h4>Ads</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-0096265772818638",
    enable_page_level_ads: true
  });
</script></p>
</div>
		</div></div><!-- .widget /--><div id="facebook-widget-2" class="widget facebook-widget"><div class="widget-top"><h4>Like Us on Facebook		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=http://www.facebook.com/balochistan.point&amp;width=300&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /--><div id="text-html-widget-2" class="widget text-html"><div class="widget-top"><h4>Text</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div >  <a class="twitter-timeline"  href="https://twitter.com/TheB_Point" data-widget-id="561154996176048129">Tweets by @TheB_Point</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>


          
				</div><div class="clear"></div></div></div><!-- .widget /--><div id="tag_cloud-2" class="widget widget_tag_cloud"><div class="widget-top"><h4>Tags</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="tagcloud"><a href="http://thebalochistanpoint.com/tag/afghan-immigrants/" class="tag-cloud-link tag-link-46 tag-link-position-1" style="font-size: 12.444444444444pt;" aria-label="Afghan Immigrants (14 items)">Afghan Immigrants</a>
<a href="http://thebalochistanpoint.com/tag/baloch/" class="tag-cloud-link tag-link-85 tag-link-position-2" style="font-size: 8pt;" aria-label="Baloch (5 items)">Baloch</a>
<a href="http://thebalochistanpoint.com/tag/balochistan/" class="tag-cloud-link tag-link-73 tag-link-position-3" style="font-size: 15.444444444444pt;" aria-label="Balochistan (27 items)">Balochistan</a>
<a href="http://thebalochistanpoint.com/tag/bpsc/" class="tag-cloud-link tag-link-129 tag-link-position-4" style="font-size: 8pt;" aria-label="BPSC (5 items)">BPSC</a>
<a href="http://thebalochistanpoint.com/tag/bus-stand/" class="tag-cloud-link tag-link-64 tag-link-position-5" style="font-size: 8.7777777777778pt;" aria-label="Bus Stand (6 items)">Bus Stand</a>
<a href="http://thebalochistanpoint.com/tag/chagai/" class="tag-cloud-link tag-link-52 tag-link-position-6" style="font-size: 14.444444444444pt;" aria-label="Chagai (22 items)">Chagai</a>
<a href="http://thebalochistanpoint.com/tag/china/" class="tag-cloud-link tag-link-140 tag-link-position-7" style="font-size: 9.8888888888889pt;" aria-label="China (8 items)">China</a>
<a href="http://thebalochistanpoint.com/tag/cnics/" class="tag-cloud-link tag-link-47 tag-link-position-8" style="font-size: 9.3333333333333pt;" aria-label="CNICs (7 items)">CNICs</a>
<a href="http://thebalochistanpoint.com/tag/corruption/" class="tag-cloud-link tag-link-44 tag-link-position-9" style="font-size: 16.333333333333pt;" aria-label="Corruption (33 items)">Corruption</a>
<a href="http://thebalochistanpoint.com/tag/cpec/" class="tag-cloud-link tag-link-63 tag-link-position-10" style="font-size: 13.777777777778pt;" aria-label="CPEC (19 items)">CPEC</a>
<a href="http://thebalochistanpoint.com/tag/deprivation/" class="tag-cloud-link tag-link-126 tag-link-position-11" style="font-size: 10.444444444444pt;" aria-label="Deprivation (9 items)">Deprivation</a>
<a href="http://thebalochistanpoint.com/tag/development/" class="tag-cloud-link tag-link-71 tag-link-position-12" style="font-size: 10.444444444444pt;" aria-label="Development (9 items)">Development</a>
<a href="http://thebalochistanpoint.com/tag/discrimination/" class="tag-cloud-link tag-link-99 tag-link-position-13" style="font-size: 12.111111111111pt;" aria-label="Discrimination (13 items)">Discrimination</a>
<a href="http://thebalochistanpoint.com/tag/earthquake/" class="tag-cloud-link tag-link-77 tag-link-position-14" style="font-size: 8pt;" aria-label="Earthquake (5 items)">Earthquake</a>
<a href="http://thebalochistanpoint.com/tag/economics/" class="tag-cloud-link tag-link-39 tag-link-position-15" style="font-size: 9.3333333333333pt;" aria-label="Economics (7 items)">Economics</a>
<a href="http://thebalochistanpoint.com/tag/education/" class="tag-cloud-link tag-link-38 tag-link-position-16" style="font-size: 22pt;" aria-label="Education (108 items)">Education</a>
<a href="http://thebalochistanpoint.com/tag/election-rigging/" class="tag-cloud-link tag-link-37 tag-link-position-17" style="font-size: 10.444444444444pt;" aria-label="Election Rigging (9 items)">Election Rigging</a>
<a href="http://thebalochistanpoint.com/tag/elections/" class="tag-cloud-link tag-link-72 tag-link-position-18" style="font-size: 10.444444444444pt;" aria-label="Elections (9 items)">Elections</a>
<a href="http://thebalochistanpoint.com/tag/electricity/" class="tag-cloud-link tag-link-75 tag-link-position-19" style="font-size: 13.777777777778pt;" aria-label="Electricity (19 items)">Electricity</a>
<a href="http://thebalochistanpoint.com/tag/famine/" class="tag-cloud-link tag-link-81 tag-link-position-20" style="font-size: 9.3333333333333pt;" aria-label="Famine (7 items)">Famine</a>
<a href="http://thebalochistanpoint.com/tag/governance/" class="tag-cloud-link tag-link-53 tag-link-position-21" style="font-size: 20.444444444444pt;" aria-label="Governance (79 items)">Governance</a>
<a href="http://thebalochistanpoint.com/tag/gwadar/" class="tag-cloud-link tag-link-50 tag-link-position-22" style="font-size: 17.777777777778pt;" aria-label="Gwadar (45 items)">Gwadar</a>
<a href="http://thebalochistanpoint.com/tag/health/" class="tag-cloud-link tag-link-66 tag-link-position-23" style="font-size: 12.666666666667pt;" aria-label="Health (15 items)">Health</a>
<a href="http://thebalochistanpoint.com/tag/human-rights/" class="tag-cloud-link tag-link-60 tag-link-position-24" style="font-size: 8pt;" aria-label="Human Rights (5 items)">Human Rights</a>
<a href="http://thebalochistanpoint.com/tag/jobs/" class="tag-cloud-link tag-link-74 tag-link-position-25" style="font-size: 8pt;" aria-label="Jobs (5 items)">Jobs</a>
<a href="http://thebalochistanpoint.com/tag/journalism/" class="tag-cloud-link tag-link-40 tag-link-position-26" style="font-size: 13.555555555556pt;" aria-label="Journalism (18 items)">Journalism</a>
<a href="http://thebalochistanpoint.com/tag/kharan/" class="tag-cloud-link tag-link-122 tag-link-position-27" style="font-size: 8pt;" aria-label="Kharan (5 items)">Kharan</a>
<a href="http://thebalochistanpoint.com/tag/literature/" class="tag-cloud-link tag-link-57 tag-link-position-28" style="font-size: 10.444444444444pt;" aria-label="Literature (9 items)">Literature</a>
<a href="http://thebalochistanpoint.com/tag/load-shedding/" class="tag-cloud-link tag-link-41 tag-link-position-29" style="font-size: 12.111111111111pt;" aria-label="Load Shedding (13 items)">Load Shedding</a>
<a href="http://thebalochistanpoint.com/tag/local-bodies/" class="tag-cloud-link tag-link-36 tag-link-position-30" style="font-size: 11.333333333333pt;" aria-label="Local Bodies (11 items)">Local Bodies</a>
<a href="http://thebalochistanpoint.com/tag/lyari/" class="tag-cloud-link tag-link-59 tag-link-position-31" style="font-size: 8.7777777777778pt;" aria-label="Lyari (6 items)">Lyari</a>
<a href="http://thebalochistanpoint.com/tag/nepotism/" class="tag-cloud-link tag-link-78 tag-link-position-32" style="font-size: 13pt;" aria-label="Nepotism (16 items)">Nepotism</a>
<a href="http://thebalochistanpoint.com/tag/nts/" class="tag-cloud-link tag-link-43 tag-link-position-33" style="font-size: 12.111111111111pt;" aria-label="NTS (13 items)">NTS</a>
<a href="http://thebalochistanpoint.com/tag/pia/" class="tag-cloud-link tag-link-125 tag-link-position-34" style="font-size: 8pt;" aria-label="PIA (5 items)">PIA</a>
<a href="http://thebalochistanpoint.com/tag/polio/" class="tag-cloud-link tag-link-115 tag-link-position-35" style="font-size: 11.333333333333pt;" aria-label="Polio (11 items)">Polio</a>
<a href="http://thebalochistanpoint.com/tag/protest/" class="tag-cloud-link tag-link-56 tag-link-position-36" style="font-size: 15.777777777778pt;" aria-label="Protest (29 items)">Protest</a>
<a href="http://thebalochistanpoint.com/tag/provincial-autonomy/" class="tag-cloud-link tag-link-45 tag-link-position-37" style="font-size: 15pt;" aria-label="Provincial Autonomy (25 items)">Provincial Autonomy</a>
<a href="http://thebalochistanpoint.com/tag/ptcl/" class="tag-cloud-link tag-link-94 tag-link-position-38" style="font-size: 8.7777777777778pt;" aria-label="PTCL (6 items)">PTCL</a>
<a href="http://thebalochistanpoint.com/tag/senate/" class="tag-cloud-link tag-link-68 tag-link-position-39" style="font-size: 8pt;" aria-label="Senate (5 items)">Senate</a>
<a href="http://thebalochistanpoint.com/tag/target-killing/" class="tag-cloud-link tag-link-51 tag-link-position-40" style="font-size: 9.8888888888889pt;" aria-label="Target Killing (8 items)">Target Killing</a>
<a href="http://thebalochistanpoint.com/tag/turbat/" class="tag-cloud-link tag-link-79 tag-link-position-41" style="font-size: 17.333333333333pt;" aria-label="Turbat (41 items)">Turbat</a>
<a href="http://thebalochistanpoint.com/tag/unemployment/" class="tag-cloud-link tag-link-104 tag-link-position-42" style="font-size: 12.444444444444pt;" aria-label="Unemployment (14 items)">Unemployment</a>
<a href="http://thebalochistanpoint.com/tag/uob/" class="tag-cloud-link tag-link-118 tag-link-position-43" style="font-size: 8pt;" aria-label="UOB (5 items)">UOB</a>
<a href="http://thebalochistanpoint.com/tag/women/" class="tag-cloud-link tag-link-69 tag-link-position-44" style="font-size: 11.666666666667pt;" aria-label="Women (12 items)">Women</a>
<a href="http://thebalochistanpoint.com/tag/youth/" class="tag-cloud-link tag-link-105 tag-link-position-45" style="font-size: 9.3333333333333pt;" aria-label="Youth (7 items)">Youth</a></div>
</div></div><!-- .widget /--><div id="ads300_250-widget-2" class="widget ads300_250-widget"><div class="widget-top"><h4> Advertisement</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div  class="ads300-250">
								<div class="ad-cell">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- thebalochpoint-300-250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8876593313238776"
     data-ad-slot="4766797649"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

			</div>
				</div>
	</div></div><!-- .widget /--><div id="text-5" class="widget widget_text"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"></div>
		</div></div><!-- .widget /--><div id="meta-2" class="widget widget_meta"><div class="widget-top"><h4>Meta</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<ul>
						<li><a href="http://thebalochistanpoint.com/wp-login.php">Log in</a></li>
			<li><a href="http://thebalochistanpoint.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://thebalochistanpoint.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</div></div><!-- .widget /--><div id="archives-2" class="widget widget_archive"><div class="widget-top"><h4>Archives</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://thebalochistanpoint.com/2020/04/'> April 2020 </option>
	<option value='http://thebalochistanpoint.com/2020/03/'> March 2020 </option>
	<option value='http://thebalochistanpoint.com/2020/02/'> February 2020 </option>
	<option value='http://thebalochistanpoint.com/2020/01/'> January 2020 </option>
	<option value='http://thebalochistanpoint.com/2019/12/'> December 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/11/'> November 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/10/'> October 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/09/'> September 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/08/'> August 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/07/'> July 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/06/'> June 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/05/'> May 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/04/'> April 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/03/'> March 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/02/'> February 2019 </option>
	<option value='http://thebalochistanpoint.com/2019/01/'> January 2019 </option>
	<option value='http://thebalochistanpoint.com/2018/12/'> December 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/11/'> November 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/10/'> October 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/09/'> September 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/08/'> August 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/07/'> July 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/06/'> June 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/05/'> May 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/04/'> April 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/03/'> March 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/02/'> February 2018 </option>
	<option value='http://thebalochistanpoint.com/2018/01/'> January 2018 </option>
	<option value='http://thebalochistanpoint.com/2017/12/'> December 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/11/'> November 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/10/'> October 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/09/'> September 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/08/'> August 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/07/'> July 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/06/'> June 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/05/'> May 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/04/'> April 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/03/'> March 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/02/'> February 2017 </option>
	<option value='http://thebalochistanpoint.com/2017/01/'> January 2017 </option>
	<option value='http://thebalochistanpoint.com/2016/12/'> December 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/11/'> November 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/10/'> October 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/09/'> September 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/08/'> August 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/05/'> May 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/04/'> April 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/03/'> March 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/02/'> February 2016 </option>
	<option value='http://thebalochistanpoint.com/2016/01/'> January 2016 </option>
	<option value='http://thebalochistanpoint.com/2015/12/'> December 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/11/'> November 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/10/'> October 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/09/'> September 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/08/'> August 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/07/'> July 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/06/'> June 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/05/'> May 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/04/'> April 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/03/'> March 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/02/'> February 2015 </option>
	<option value='http://thebalochistanpoint.com/2015/01/'> January 2015 </option>
	<option value='http://thebalochistanpoint.com/2014/12/'> December 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/11/'> November 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/10/'> October 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/09/'> September 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/08/'> August 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/07/'> July 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/06/'> June 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/05/'> May 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/04/'> April 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/03/'> March 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/02/'> February 2014 </option>
	<option value='http://thebalochistanpoint.com/2014/01/'> January 2014 </option>
	<option value='http://thebalochistanpoint.com/2013/12/'> December 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/11/'> November 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/10/'> October 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/09/'> September 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/08/'> August 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/07/'> July 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/06/'> June 2013 </option>
	<option value='http://thebalochistanpoint.com/2013/05/'> May 2013 </option>
	<option value='http://thebalochistanpoint.com/2012/09/'> September 2012 </option>
	<option value='http://thebalochistanpoint.com/2012/07/'> July 2012 </option>

		</select>
		</div></div><!-- .widget /--></aside>
<div class="clear"></div>		<div class="clear"></div>
	</div><!-- .container /-->

		</div><!-- .container -->

	<footer id="theme-footer" class="fade-in animated4">
	<div id="footer-widget-area" class="narrow-wide-2c container">

			<div id="footer-first" class="footer-widgets-box">
			<div id="text-html-widget-4" class="footer-widget text-html"><div class="footer-widget-top"><h4>About us</h4></div>
						<div class="footer-widget-container"><div >The Balochistan Point is an online English newspaper from Balochistan, launched on October 16, 2010. The Balochistan Point is an online newspaper and works without any bias towards any race, religion or political ideology. The core values of The Balochistan Point shape up an independent editorial policy for the newspaper. We at The Balochistan Point believe on Objective Journalism and avoid any news item based upon allegation or speculations. Due to our indefatigable effort to disseminate the important and correct news about Balochistan, we aim to be the voice of the nation.
				</div><div class="clear"></div></div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="youtubechannelgallery_widget-2" class="footer-widget youtubechannelgallery ytccf"><div class="footer-widget-top"><h4>Videos</h4></div>
						<div class="footer-widget-container"><div class="vmcerror">Error type: "Bad Request". Error message: "Bad Request" Domain: "usageLimits". Reason: "keyExpired". <br><br>Did you added your own Google API key? Look at the <a href="http://poselab.com/en/youtube-channel-gallery-help" target="_blank">help</a>.<br><br>Check in YouTube if the id <a href="https://www.youtube.com/channel/UCjz3bH1HgvKEtU_dBFjCOzQ" target="_blank">UCjz3bH1HgvKEtU_dBFjCOzQ</a> belongs to a channelid. Check the <a href="http://wordpress.org/extend/plugins/youtube-channel-gallery/faq/" target="_blank">FAQ</a> of the plugin or send error messages to <a href="https://wordpress.org/support/plugin/youtube-channel-gallery" target="_blank">support</a>.</div></div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
					</div><!-- #third .widget-area -->
	
	
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
	<div class="clear"></div>
	<div class="footer-bottom fade-in animated4">
		<div class="container">
					<div class="social-icons icon_flat">
		<a class="ttip" title="Rss" href="http://thebalochistanpoint.com/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="http://www.facebook.com/Balochistan.Point" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="http://twitter.com/TheB_Point" target="_blank"><i class="tieicon-twitter"></i></a>	</div>

			<div class="alignleft">
			Copyright © TheBalochistanPoint.com			</div>
		</div><!-- .Container -->
	</div><!-- .Footer bottom -->

</div><!-- .Wrapper -->
	<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
        <div id="fb-root"></div>
        <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1727391854220459&version=v2.3";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>	
          <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<link rel='stylesheet' id='dashicons-css'  href='http://thebalochistanpoint.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://thebalochistanpoint.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"http:\/\/thebalochistanpoint.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://thebalochistanpoint.com/wp-content/themes/jarida/js/tie-scripts.js'></script>
<script type='text/javascript' src='http://thebalochistanpoint.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/thebalochistanpoint.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thebalochistanpoint.com/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thebalochistanpoint"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thebalochistanpoint.com/wp-content/plugins/disqus-comment-system/media/js/count.js'></script>
</body>
</html>
